Skip to main content
Biamp Systems

Exporting Vocia logs

This article explains how to export a Vocia log file and read it using an XML reader such as Microsoft Excel.

This is a two-step process:

  1. Exporting the Log file from the Vocia Log Viewer
  2. Opening or Importing the Log using a XML reader such as Microsoft Excel.

Prerequisites

  • To Export the Vocia log files, the Vocia Software is required.
  • To review the Vocia Logs, an XML reader such as Microsoft Excel is required.

Exporting the log

  1. Connect to a running Vocia system using Vocia software
  2. Open the Vocia Log Viewer, available via the Network > Log Viewer menu or CTRL+L Shortcut.
  3. Confirm the Log is showing the relevant data which requires review. If not, all available log events can be retrieved by selecting Clear Local Logs then Download. This function will interrogate the devices for their event log information which will then be displayed in the Log Viewer dialog.
  4. Select Export and save the XML file to a local drive location.
  5. Send the XML file to Biamp support or review it using a suitable XML reader.

Reading the log

Once the log has been exported, you can either open it in a spreadsheet program such as Excel, or import it into an existing spreadsheet.  The instructions below are for using Microsoft Excel to open or import the XML file.

Open

A Vocia Log is in an XML format. Ideally the data should be opened in a spreadsheet program such as Excel.

Please review the steps below:

1. Open Excel.

2. Go to File > Open.

3. Browse to where the XML log file is stored.

device_log.png

4. You will get an Open XML dialog that enables you to select how to open the file. Select As an XML table. Press OK.

Open XML.png

5. You may get some XML Import errors. Disregard these and select OK.

XML Import Error.png

6. The imported log data will be displayed in a table. There are sort fields at the top of the document that allow filtering if you need it.

Example log.png

7. This can then be saved in a different format if required.

Import

A Vocia Log is in an XML format. This can be opened in a text format using a program such as Notepad or Word. This does not allow much flexibility in searching or filtering any results. Ideally the data should be opened in a spreadsheet program such as Excel.

To open an XML document using Excel the data has to be imported into an open Excel document. Please review the steps below:

1. Open Excel.

2. Go to File > Open > Blank Workbook.

3. Go to Data >From Other Sources > From XML Data Import.

XML data Import.png

4. Browse to where the XML log file is stored.

device_log.png

5. You will get an Import Data dialog that enables you to specify the placing of the data in the spreadsheet. Press OK.

6. You may get some XML Import errors. Disregard these and select OK.

XML Import Error.png

7. The imported log data will be displayed in a table. There are sort fields at the top of the document that allow filtering if you need it.

Example log.png

8. This can then be saved in a spreadsheet format if required.

  • Was this article helpful?