Enabling AVB on Cisco Catalyst Switches
This article describes how to enable AVB on supported Cisco® Catalyst® switches. This article does not detail Cisco firmware upgrade or initial switch setup procedure. Please see Cisco Catalyst documentation for more detail. Biamp recommends a Cisco certified technician performs switch configuration.
Supported Catalyst models
AVB is supported on select models of the following Catalyst series.
Please always check Cisco AVB for all current information and updates.
Please always reach out to Cisco Support for assistance and further information.
Catalyst 3650 Series | Catalyst 3850 Series | Catalyst 9300 Series | Catalyst 9500 Series |
---|---|---|---|
Required license level: ipbase or ipsevices |
Required license level: ipbase or ipsevices |
Required license level: Network Advantage |
Required license level: Network Advantage |
Cisco minimum: IOS XE Gibraltar 16.12.9 |
Cisco minimum: IOS XE Gibraltar 16.12.9 |
Cisco minimum: IOS XE Bengaluru 17.6.5 |
Cisco minimum: IOS XE Bengaluru 17.6.5 |
C3650-24PDM C3650-48FQM C3650-8X24PD C3650-8X24UQ C3650-12X48FD C3650-12X48UQ C3650-12X48UR C3650-12X48UZ |
C3850-12X48U C3850-24XU C3850-12XS C3850-16XS C3850-24XS C3850-32XS C3850-48XS |
All models. | C9500-12Q C9500-16X C9500-24Q C9500-40X |
NOTE: For the following Cisco models, PTP is not supported on all ports. We can not recommend these.
- C9300-48UXM only ports 1-16, 18-34, 36, 38, 44 support PTP.
- C9300-48UN only ports 1-36, 38 support PTP.
Catalyst 3650 and 3850 series switches have been certified by the Avnu Alliance.
Catalyst 9300 and 9500 series switches have been certified by the Avnu Alliance.
The following Cisco license levels are required for AVB support.
- ipbase or ipservices license level for Catalyst 3000 family.
- Network Advantage for Catalyst 9000 family.
- DNA Subscription license not required for AVB support.
Cisco recommends the following minimum Cisco IOS® XE Software release versions are required for AVB support.
- IOS XE Gibraltar 16.12.9 for Catalyst 3000 family.
- IOS XE Bengaluru 17.6.5 for the Catalyst 9000 family
Please always follow Cisco recommendations for newer versions of IOS.
Limitations
Cisco Catalyst IOS applies following limitations apply when AVB is enabled:
- AVB is not supported on StackWise connected switches. Fiber and copper uplinks are supported.
- AVB is not supported on ports that are combined using link aggregation (EtherChannel).
- Cisco published stream limit per switch is 200.
Enabling AVB
Prerequisites:
- Cisco IOS XE Software with AVB support.
- Switches have appropriate license levels.
- User has access to CLI with configure permissions.
- Switches are not in stacking mode
- Interfaces are not configured for Etherchannel
- Default VLAN 1 / Native VLAN 1 must be enabled on all switches.
- Default username cisco. The default password is the serial number of the switch chassis.
Step 1 - Enable VLAN 1
Command | Note |
---|---|
Switch> enable | Enable EXEC mode. |
Switch# configure terminal | Enter global configuration mode. |
Switch(config)# Vlan 1 | Create VLAN 1 |
Switch(config)# interface Vlan1 | Configure Interface VLAN 1 |
Switch(config-if)# ip address < 192.168.1.XXX 255.255.255.0 > | Unique reachable IP address for each switch. |
Switch(config-if)# no shutdown | Ensure the interface is not shut down. |
Switch(config-if)# end | End global configuration mode. |
Switch# write memory | Save the switch configuration. |
Step 2 - Enable AVB
Enter the following commands to enable AVB and MVRP (automatic VLAN) on the switch.
Command | Note |
---|---|
Switch> enable | Enable EXEC mode. |
Switch# configure terminal | Enter global configuration mode. |
Switch(config)# avb vlan 2 | Enable AVB vlan 2 |
Switch(config)# avb | Enable AVB. |
Switch(config)# mvrp global | Enter MVPR global configuration. |
Switch(config)# vtp mode off | VLAN Trunking Protocol (VTP) can be configured for off or transparent mode operation. |
Switch(config)# mvrp vlan create | Enable MVRP to create VLANs |
Switch(config)# avb msrp-join-timer 200 | Set MSRP join timer to expected value |
Switch(config)# avb msrp-leave-timer 5000 | Set MSRP leave timer to expected value |
Switch(config)# avb msrp-leaveall-timer 25000 | Set MSRP leave-all timer to expected value |
Switch(config)# qos queue-softmax-multiplier 1200 | QOS increase this buffer requested by Cisco |
Switch(config)# end | End global configuration mode. |
Switch# write memory | Save the switch configuration. |
Advanced variables only needed if you need to manually adjust the pdelay between switches on large networks.
Command | Note |
---|---|
Switch> enable | Enable EXEC mode. |
Switch# configure terminal | Enter global configuration mode. |
Switch(config)# ptp neighbor-propagation-delay-threshold 2000 | Only change this when you see the delay on the AVB ports exceed default. Typical AVB 1gb endpoint will be ~80ns. Default 800. |
Switch# write memory | Save the switch configuration. |
For further details, see the Cisco IOS XE command reference guide for configuring Audio Video Bridging.
Step 3 - Configure interfaces with AVB connections to VLAN trunk mode.
Any ports with AVB devices attached must be configured for VLAN trunking mode. The port must also not be administratively shutdown. The following commands show enabling trunk mode for interface GigabitEthernet1/0/1.
Command | Note |
---|---|
Switch> enable | Enable EXEC mode. |
Switch# configure terminal | Enter global configuration mode. |
Switch(config)# interface GigabitEthernet1/0/1 | Enter interface configuration mode. |
Switch(config-if)# description AVB ENDPOINT | Description of what the port is used for. |
Switch(config-if)# switchport mode trunk | Configure VLAN mode to trunk. |
Switch(config-if)# spanning-tree portfast trunk | Interface directly to spanning-tree forwarding state. |
Switch(config-if)# switchport trunk allowed vlan 1,2 | Only allow the needed VLANS for AVB 1, 2 |
Switch(config-if)# ptp sync interval -2 | Set PTP sync interval log value slower. (optional) |
Switch(config-if)# no shutdown | Ensure the port is not shut down. |
Switch(config-if)# end | End configuration mode. |
Switch# write memory | Save switch configuration to memory. |
Configuring port by port is time consuming. The following is an example for configuring all ports 1-24 using the interface range command:
- Switch>enable
- Switch#configure terminal
- Switch(config)#interface range GigabitEthernet1/0/1 - 24
- Switch(config-if-range)#description AVB ENDPOINT
- Switch(config-if-range)#switchport mode trunk
- Switch(config-if-range)#spanning-tree portfast trunk
- Switch(config-if-range)#switchport trunk allowed vlan 1,2
- Switch(config-if-range)#ptp sync interval -2
- Switch(config-if-range)#no shutdown
- Switch(config-if-range)#end
- Switch#write memory
- Switch#exit
Step 4 - Optional Configuration of interfaces connecting to devices requiring class 4 (POE+ and PPoE).
Biamp class 4 devices will require additional 2-event classification commands to negotiate with Cisco Power Sourcing Equipment (PSE).
Cisco indicates 2-event classification allows class 4 Powered devices (PDs) to detect a PSE capability of providing 30W from hardware then register itself moving upward to PoE+ level without waiting for any CDP/LLDP packet exchange.
After 2-event is enabled on a port, you must manually shut/un-shut the port or re-connect the PD again to re-start the IEEE detection process.
Note that power budget allocation for a class-4 device will be 30W when 2-event classification is enabled on the port; otherwise it will be 15.4W.
The following is an example for configuring all ports 1-24 using the interface range command, 2-event POE configuration with additional easy to identify interface description of BIAMP on the ports:
Switch>enable
Switch#configure terminal
Switch(config)#interface range GigabitEthernet1/0/1 - 24
Switch(config)#description BIAMP
Switch(config-if-range)#power inline port 2-event
Switch(config-if-range)#shutdown
Switch(config-if-range)#no shutdown
Switch(config-if-range)#end
Switch#write memory
Switch#exit
The switch does not require a reboot. Connected AVB enabled end points will begin transmitting protocol messages within moments of configuring the switch. Many other specific configuration options are available for the AVB protocols. Please see the IOS XE command reference guides for further details.
AVB status and monitoring commands
The following commands are used to view the status of AVB on the switch and for assisting with diagnosing issues.
Command | Note |
---|---|
show msrp stream | count : | Shows the total amount of AVB streams registered in msrp. |
show avb stream | count Ready | Shows the total amount of AVB streams on the switch. |
show avb domain | Shows a high level overview of AVB operation on the switch. Displays stream reservation domain active ports, gPTP neighbor delay and VLAN membership. |
show avb stream | Displays a high level overview of all AVB streams advertised on the network. |
show msrp streams brief | Provides a brief view of AVB streams on the network. |
show msrp streams detail | Provides a detailed output of AVB streams and reservations on the network. |
show msrp port bandwidth | Shows current stream reservation consumption on the switch ports. |
show mvrp summary | Shows a summary of VLANs created automatically. |
show mvrp interface | Displays interface specific MVRP details. |
show ptp brief | Shows a brief overview of gPTP operation. |
show ptp clock | Shows the current clock details. |
show ptp parent | Shows details of the parent clock. |
show platform software fed switch active ptp if-id {interface-id} | Detailed output of the gPTP operation of a port. Provides neighbor delay threshold and current measured neighbor delay. |
show version | Shows details of the switch's software version. See Enabling AVB on Cisco Catalyst Switches |
show license right-to-use | Shows details of the switch's enabled licenses. See Enabling AVB on Cisco Catalyst Switches |
Further reading
- List of AVB-capable Ethernet switches
- Understand AVB in Catalyst 3K and Catalyst 9000 Series Switches
- Cisco.com AVB website
- Cisco.com AVB resources
- Cisco Audio Video Bridging Configuration Guide, Cisco IOS XE Gibraltar 16.12.x (Catalyst 3850 Switches)
- Release Notes for Cisco Catalyst 3850 Series Switches, Cisco IOS XE Gibraltar 16.12.x
- Cisco Audio Video Bridging Configuration Guide, Cisco IOS XE Gibraltar 16.12.x (Catalyst 3650 Switches)
- Release Notes for Cisco Catalyst 3650 Series Switches, Cisco IOS XE Gibraltar 16.12.x
- Command Reference, Cisco IOS XE Cupertino 17.7.x (Catalyst 9300 Switches)
- Configuring 2-event (PoE+) Classification
- Extensive PoE Configuration details - C3850
- "POE in depth" Biamp Cornerstone